FS S3900 SERIES SWITCHES

Overview

The S3900 series switches consist of three models: S3900-24T4S, S3900-24F4S, S3900-48T4S, which are fully managed stackable Gigabit switches, equipped with Broadcom chips, supporting 10G SFP+ uplinks, designed for SMB, campus and enterprise networks.

S3900-24T4S S3900-24F4S S3900-48T4S

Product Guideline

Product Guideline

Case Study

Download

FAQ

Basic Information
Overview
Test Report
EOM, EOFS and EOS Date
Supported Module & Cable
Configuration Guide
Switch Stack
Voice VLAN
STP Configuration
Interface-based VLAN
IP Subnet-based VLAN
Protocol-based VLAN
Traffic Segmentation
Log in Guide
Port Mirroring
MAC Address-based VLAN
LACP
SNMP
DHCP Snooping

Port Mirroring Configuration on S3900 Series Switches

Posted on By FS.COM

Port mirroring is used on a network switch or router to send copies of packets on the specified ports (source ports) to other specified ports (destination ports). FS S3900 series switches are the ideal Gigabit access and aggregation switches for SMB, enterprise and campus networks. They support port mirroring to help users monitor and analyze network traffic, and debug data or diagnose errors on a network.

Port Mirroring Application on S3900 Series Switches

Port mirroring includes local port mirroring and remote port mirroring based on the working range of mirroring.

Local Port Mirroring Application

Choose local mirroring mode when source ports and destination ports are on one S3900 switch. Take S3900-48T4S port mirroring application as an example. Once port mirroring is set, the source port (11) will copy the packet to the destination port (10), then users can use the monitoring device to monitor and analyze data from the client device.

local port mirroring appliacation.jpg

Remote Port Mirroring Application

In remote mirroring, source ports and destination ports do not belong to one S3900 switch. Destination port on one switch can monitor the source port on another switch via the connection between the two different switches. Take remote port mirroring application of S3900-48T4S and S3900-24T4S as an example. Set S3900-48T4S port (5) as the source port, and set S3900-24T4S port (5) as the destination port. And make an uplink connection between the two switches via the ports (10) on two sides. Thus, users can use the monitoring device connected to S3900-24T4S to monitor and analyze the data from the client device connected to S3900-48T4S switch.

remote port mirroring application.jpg

Hardware Connection for Port Mirroring of S3900 Series Switches

SS3900 series switches consist of S3900-24F4S, S3900-24T4S and S3900-48-T4S. All support port mirroring. Rates of source port and destination port should be matched when applying local and remote port mirroring. Sometimes, the destination port rate can be higher than that of the source port, but never less than that of the source port.

port mirroring connection.jpg

Note that:


  • Configuration takes effect after setting one port as the source port and setting another port as the destination port in local port mirroring.

  • When creating a mirroring group, only one destination port can be set, but there could be one or more source ports in the group.

  • If one port has been specified as the source port in one mirroring group, it can’t be a member of another mirroring group.

  • If one port has been specified as the destination port in one mirroring group, it can’t be a member of another mirroring group.

  • It’s recommended that do not apply STP, RSTP or MSTP on the destination port, otherwise, the device may malfunction.

Port Mirroring Configuration Roadmap of S3900 Series Switches

Running local and remote port mirroring on S3900 series switches can be achieved by CLI and web interface. Here uses CLI configuration as an example.

Local Port Mirroring Configuration Roadmap


  • Create a VLAN.

  • Add the source port and destination port to VLAN.

  • Configure IP address.

  • Configure port mirroring on the destination port, and copy the packet from the source port to the destination port.

  • Verify the results.

Remote Port Mirroring Configuration Roadmap


  • Specify the source port in a global schema.

  • Configure the uplink port on one switch.

  • Specify the destination port in a global schema.

  • Verify the results.

S3900 Series Switches Local Port Mirroring Configuration via CLI

1. Create VLAN 10 on S3900-48T4S. Set the port (10) mode as Access and add the port to VLAN 10.

S3900-48T4S#configure terminal

S3900-48T4S(config)#vlan database

S3900-48T4S(config-vlan)#vlan 10

S3900-48T4S(config)#interface ethernet 1/10

S3900-48T4S(config-if)#switchport mode access

S3900-48T4S(config-if)#switchport access vlan 10

2. Create VLAN 11. Set the port (11) mode as Access and add the port to the VLAN 11.

S3900-48T4S(config)#vlan database

S3900-48T4S(config-vlan)#vlan 11

S3900-48T4S(config)#interface ethernet 1/11

S3900-48T4S(config-if)#switchport mode access

S3900-48T4S(config-if)#switchport access vlan 11

3. Configure IP address of VLAN 10 and VLAN 11.

S3900-48T4S(config)#interface vlan 10

S3900-48T4S(config-if)#ip add 192.168.3.11 255.255.255.0

S3900-48T4S(config)#interface vlan 11

S3900-48T4S(config-if)#ip add 192.168.2.11 255.255.255.0

4. Configure port mirroring on the destination port (10).

S3900-48T4S(config)#interface ethernet 1/10

S3900-48T4S(config-if)#port monitor ethernet 1/11 both

5. Verify the results by the software of capturing packet Wireshark. Users can use the destination port (10) to capture the packet from the source port (11). This means port mirroring is successfully configured.

local port mirroring result.jpg

S3900 Series Switches Remote Port Mirroring Configuration via CLI

1. Set S3900-48T4S port (5) as the source port.

S3900-48T4S#configure terminal

S3900-48T4S(config)#vlan database

S3900-48T4S(config-vlan)#vlan 200 media ethernet rspan

S3900-48T4S(config-vlan)#exit

S3900-48T4S(config)#rspan session 1 source interface e 1/5

2. Configure S3900-48T4S port (10) as the uplink port.

S3900-48T4S(config)#rspan session 1 remote vlan 200 source uplink e 1/10

3. Set S3900-24T4S port (5) as the destination port.

S3900-24T4S#configure terminal

S3900-24T4S(config)#vlan database

S3900-24T4S(config-vlan)#vlan 200 media ethernet rspan

S3900-48T4S(config-vlan)#exit

S3900-24T4S(config)#rspan session 1 destination interface e 1/5

4. Configure S3900-24T4S port (10) as the uplink port.

S3900-24T4S(config)#rspan session 1 remote vlan 200 destination uplink e 1/10

5. View the configuration

S3900-48T4S#show rspan session

RSPAN Session ID : 1

Source Ports (mirrored ports)

RX Only : None

TX Only : None

BOTH : Eth 1/5

Destination Port (monitor port) : None

Destination Tagged Mode : None

Switch Role : Source

RSPAN VLAN : 200

RSPAN Uplink Ports : Eth 1/10

Operation Status : Up

6. Verify the results by the software of capturing packet Wireshark. Users can use the destination port (5) on S3900-24T4S to capture the ICMP packet from the source port (5) on S3900-48T4S. This means remote port mirroring is successfully configured.

remote port mirroring result.jpg

Related Articles:

Voice VLAN Configuration on FS S3900 Series Switches
Traffic Segmentation Configuration on FS S3900 Series Switches

Name
All Type
Date
File