FS S3900 SERIES SWITCHES

Overview

The S3900 series switches consist of three models: S3900-24T4S, S3900-24F4S, S3900-48T4S, which are fully managed stackable Gigabit switches, equipped with Broadcom chips, supporting 10G SFP+ uplinks, designed for SMB, campus and enterprise networks.

S3900-24T4S S3900-24F4S S3900-48T4S

Product Guideline

Product Guideline

Case Study

Download

FAQ

Basic Information
Overview
Test Report
EOM, EOFS and EOS Date
Supported Module & Cable
Configuration Guide
Switch Stack
Voice VLAN
STP Configuration
Interface-based VLAN
IP Subnet-based VLAN
Protocol-based VLAN
Traffic Segmentation
Log in Guide
Port Mirroring
MAC Address-based VLAN
LACP
SNMP
DHCP Snooping

Voice VLAN Configuration on FS S3900 Series Switches

Posted on By FS.COM

A voice VLAN is a VLAN ( virtual local area network) that is specifically allocated for user's voice data streams. It ensures the quality of a voice service due to the priority of voice stream transmission when other services (video or data services) are transmitted simultaneously. FS S3900 series switches, designed for campus network, SMB and home network, also support voice VLAN.

Voice VLAN Application on FS S3900 Series Switches

Normally, voice VLAN can identify voice data streams sent from an IP phone in two ways. Take FS S3900 series switches (S3900-24T4S, S3900-24F4S, and S3900-48T4S) as an example. These switches can identify voice data based on both source MAC addresses and source VLAN tags of the received packets. The MAC address-based mode and VLAN-based mode share the same diagram as follow. Once voice streams are identified, they will be prioritized and transmitted with a higher forwarding priority than data or video services.

voice VLAN-1.jpg

Hardware Connection Guide for Voice VLAN of S3900 Series Switches

The FS S3900 series switches offer 1G RJ45 ports, 1G SFP ports and 10G SFP+ ports, all of which support voice VLAN configuration. An IP phone provides an RJ45 network port or WiFi signal, different from an ordinary phone with RJ11 port. Therefore, there are two types of copper connection (with or without copper transceiver) between an IP phone and S3900 series switches to realize voice VLAN, of which option 1 with just a single copper cable is the mostly adopted method.

voice VLAN-2.jpg

Voice VLAN Configuration Roadmap of S3900 Series Switches

By configuring voice VLAN, the priority of voice data can be improved. The configuration roadmaps of MAC address-based mode and VLAN-based mode are shown as following.

Note: The FS 3900 switches can not support voice VLAN when the switch port is under access mode.

MAC Address-based Mode

The voice packets and data packets received by the switch are untagged packets, you need to configure the organizationally unique identifier (OUI) to distinguish voice and data traffic. Use the following steps:


  • Create a VLAN on the switch and add interfaces to the VLAN to implement Layer 2 interworking.

  • Configure the OUI to match the source MAC address of the received packet.

  • Configure the voice VLAN function on the interface.

VLAN-based Mode

You need to manually set the corresponding VLAN on the IP Phone. When the switch received tagged packets from IP phone, the configuration includes two main steps:


  • Create a VLAN on the switch and add interfaces to the VLAN to implement Layer 2 interworking.

  • Configure VLAN 2 as the voice VLAN and use the VLAN-based voice VLAN (this is the default setting). You do not need to configure the cumbersome OUI, which simplifies the configuration.

S3900 Series Switch Voice VLAN Configuration Via CLI

The following will demonstrate the detailed voice VLAN configuration process of FS S3900 switches (take S3900-48T4S as an example) via command-line interface (CLI) on both MAC address-based mode and VLAN-based mode.

Configuration on MAC Address-based Mode

1. Create a VLAN

S3900-48T4S#configure terminal
S3900-48T4S (config)#vlan database
S3900-48T4S (config-vlan)#vlan 2

2. Configure the VLAN to allow ethernet 1/1 and ethernet 1/2 interface to pass.

S3900-48T4S(config)#interface ethernet 1/1
S3900-48T4S(config-if)#switchport mode hybrid
S3900-48T4S(config-if)#switchport hybrid pvid 2
S3900-48T4S(config-if)#switchport hybrid allowed vlan add 2 untagged
S3900-48T4S(config)#interface ethernet 1/2
S3900-48T4S(config-if)#switchport mode trunk
S3900-48T4S(config-if)#switchport trunk allowed vlan add 2

3. Configure the OUI to match the source MAC address (the MAC address of the IP phone, here is 64-9D-99-1F-02-02) of the received packet.

S3900-48T4S(config)#voice vlan 2
S3900-48T4S(config)#voice vlan mac-address 64-9D-99-00-00-00 mask ff-ff-ff-00-00-00 description voice

4. Configure the voice VLAN function on the interface.

S3900-48T4S(config)#interface ethernet 1/1
S3900-48T4S(config-if)#switchport voice vlan auto
S3900-48T4S(config-if)#switchport voice vlan priority 6
S3900-48T4S(config-if)#switchport voice vlan rule oui
S3900-48T4S(config-if)#switchport voice vlan security

5. Check the configuration results.

S3900-48T4S#show voice vlan status
voice vlan 1.png

S3900-1#show voice vlan oui
voice vlan 2.png

Configuration on VLAN-based Mode

1. Create a VLAN

S3900-48T4S#configure terminal
S3900-48T4S (config)#vlan database
S3900-48T4S (config-vlan)#vlan 2

2. Configure the VLAN to allow ethernet 1/1 and ethernet 1/2 interface to pass.

S3900-48T4S(config)#interface ethernet 1/1
S3900-48T4S(config-if)#switchport mode hybrid
S3900-48T4S(config-if)#switchport hybrid allowed vlan add 2 tagged
S3900-48T4S(config)#interface ethernet 1/2
S3900-48T4S(config-if)#switchport mode trunk
S3900-48T4S(config-if)#switchport trunk allowed vlan add 2

3. Configure VLAN 2 as a voice VLAN and use a VLAN-based voice VLAN.

S3900-48T4S(config)#voice vlan 2
S3900-48T4S(config)#interface ethernet 1/1
S3900-48T4S(config-if)#switchport voice vlan auto
S3900-48T4S(config-if)#switchport voice vlan priority 6

4. Check the configuration results.

S3900-48T4S#show voice vlan status
voice vlan 3.png

Related Articles:

Stack Configuration on FS S3900 Series Switches
Traffic Segmentation Configuration on FS S3900 Series Switches

Name
All Type
Date
File